WordPress 5.1 Released (Many WordPress Theme Crashed) - What to do?

Joined
Jan 1, 2019
Messages
56
Best answers
0
Ratings
22
Points
8
#1
Hi friends,

This post is for informational purposes only.

Many of us are using WordPress CMS and using free or paid themes.
On 21st Feb 2019, WordPress 5.1 “Betty” Released and many themes backward compatibility break in WordPress 5.1.

WordPress themes providers have already reported it to the WordPress core team.
Now what you have to do if your WordPress theme has also broke.

For now, please log into your website/blog admin panel and revert back to the latest 5.0 version using this plugin:

Install wp-downgrade WordPress plugin and revert your WordPress version to 5.0.

https://wordpress.org/plugins/wp-downgrade/

Note: Don't forget to report this problem to your WordPress theme provider so that they can release the new WordPress theme at the earliest.
 
Last edited:
Joined
Jan 3, 2019
Messages
58
Best answers
6
Ratings
15
Points
8
#2
First of all thanks for offering this help. I am running my blog on a wordpress theme. I hope this plugin will be useful for me.
I think its a big issue. Many bloggers did hard work to promote their blogging strategy. You should complain this issues to the wordpress and you also need to discus with other community blogger.

It is necessary to shootout this issue. This issue can become the major enemy for your online business.
 
Joined
Jan 1, 2019
Messages
56
Best answers
0
Ratings
22
Points
8
#3
anilkvm85
This issue has already been reported to WordPress but Yes, this issue is not with every WordPress theme.

WordPress is developed by highly skilled people who are continuously contributing to the community without any return. They are doing their best. They have made a changes for betterment of the WordPress future which should be appreciated.

There is a learning with every change.

We should apply every update on any dummy WordPress website or Sub-Domain Website to see the effect of change with same WordPress theme and Plugin. I did the same with my demo website which got crash. So always apply changes on dummy website. If everything works fine, we should apply on main website.

This is what we can do... That's why I opened this thread to transfer my knowledge and experience.
 
Joined
Jan 3, 2019
Messages
58
Best answers
6
Ratings
15
Points
8
#4
56ajjusingh
Well said Anil,
Wordpress is very modern platform and developed and maintain by highly professional developers.
Thanks for your efforts. We (hostnetindia) also always try to help people regarding web hosting, development level so that bloggers who are new in digital crowd they could find right information.
 

Kaz Wolfe

Well-known member
Joined
Jul 7, 2016
Messages
385
Best answers
0
Ratings
30
Points
28
#5
Why do we need downgrade when upgraded to this version?
I read that Wordpress gave an option to use classic editor and that will not brake your WP site.
 
Joined
Jan 1, 2019
Messages
56
Best answers
0
Ratings
22
Points
8
#6
anilkvm85
This is not about classic editor.

In the WordPress 5.1 release dated 21st Feb 2019, many WordPress themes backward compatibility broke and their website start giving following error..

Fatal error: Call to a member function hook() on null in /www/htdocs/w00afaca/wp-content/themes/TechTrend/header.php on line 6

That's why I wrote to downgrade till their WordPress theme provider fixes the issue.
 
Latest Threads
Replies
0
Views
2
  • Deleted
  • Deleted by fwh
Replies
0
Views
1
Replies
0
Views
1
Replies
1
Views
21
  • Deleted
  • Deleted by fwh
Replies
0
Views
1

Latest Hosting OffersNew Reviews

Sponsors

Latest Blog ArticlesMost Viewed Threads

Tag Cloud

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top