500 Internal Server Error when enabling friendly urls

Cookie123

New member
Registered
Joined
Jun 25, 2021
Messages
1
Points
1
So I enabled Friendly URLs for my XF forum, and it worked fine, but all of a sudden it said this:
1626456018347.png
I use cPanel, and when I try to access the error logs it gives a 403 error.

Anyways, it was working fine for like 15 min.. I didn't change anything in my htaccess
This was the htaccess I was using:
Apache config:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

        RewriteCond %{SERVER_PORT} 80
        RewriteRule ^(.*)$ https://forums.(hidden)/$1 [R,L]

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /

    #    This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
I put (hidden) to hide my domain.
It doesn't say (hidden) in the htaccess
 

swetajoshi

New member
Registered
Joined
Jun 29, 2021
Messages
4
Points
1
if you use apache server you must enable rewrite_module in httpd.conf, You can find httpd.conf in C:\wamp\bin\apache\apache2.4.9\conf directory. this is my directory, this directory may change therefore you must use your directory.
Then you go line:
#LoadModule rewrite_module modules/mod_rewrite.so

and remove (#).You must change such as the following code.

LoadModule rewrite_module modules/mod_rewrite.so

save and close httpd.conf file.Restart your apache server.
 

JTexan

Member
Collaborate
Registered
Joined
Dec 5, 2014
Messages
37
Points
8
Try to run a simple file like test.php or test.html and see if it still having that error.

if yes, that's error from your server, if no, you need to check file permission for your files or folder and don't forget to check codes in htaccess file if all of them are correct or not. :)
 

hostguy

Member
Registered
Joined
Sep 9, 2020
Messages
40
Points
6
500 errors are occurred due to server side, so if possible first confirm with your hosting provider.
Try to rename your .htaccess file and then access your website, if you are getting any issue then check file permission and PHP version.
 

RoseHosting

Active member
Hosting Provider
Registered
Joined
Jun 16, 2016
Messages
68
Points
8
The 500 internal server error is a very general HTTP status code. It is issue related to the webserver itself, and the hosting company will take care of it for sure.
 
Older Threads
Newer Threads
Replies
4
Views
501
Replies
23
Views
1,668
Replies
1
Views
1,228
Latest Threads
Replies
0
Views
33
Replies
2
Views
91
Replies
2
Views
296
Replies
24
Views
577

Sponsors

Latest Blog ArticlesMost Viewed Threads

Tag Cloud

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top