Putty connection refused?

Joined
Nov 9, 2013
Messages
63
Best answers
0
Ratings
6 2
Points
8
#1
When i am logging into my server using Putty, I got this error: Putty connection refused

putty connection refused.jpg

Is this network error or my hosting is getting down/error? please help. Thanks
 

hostens

Well-known member
Joined
Jan 18, 2017
Messages
174
Best answers
2
Ratings
64 7
Points
28
#2
It usually means that the PuTTY settings are not set correctly for logging in. You should use these settings:

-- Host Name: enter IP of your server
-- Port: 22 (leave as default)
-- Connection Type: SSH (leave as default)
Then Click "Open" to start the SSH session. If this is your first time connecting to the server from this computer, you will see "PuTTY Security Alert" table. Accept the connection by clicking "Yes". Once the SSH Connection is open, you should see a terminal prompt asking for your username. Next, enter your password. Please note that you will NOT see your cursor moving, or any characters typed, when typing your password. This is a standard PuTTY security feature. After you typed it in hit enter.

Make sure you have a correct password. Also one of the other possible reasons could be that your device is blocking the connection or the port you are using.
 
Joined
Nov 9, 2013
Messages
63
Best answers
0
Ratings
6 2
Points
8
#3
OnaDavney
It usually means that the PuTTY settings are not set correctly for logging in. You should use these settings:

-- Host Name: enter IP of your server
-- Port: 22 (leave as default)
-- Connection Type: SSH (leave as default)
I filled right information as you said and I tried to check my control panel and I still could logged into it. I think I was blocked by iptables or something else on my server. Honestly I have tried to change ssh port before from 22 to 45, but now I also can not login with this port. How to use my hosting control panel (cPanel) to unblock these ports?
 

Malware.Expert

Corporate Member
Corporate Member
Joined
Jun 18, 2018
Messages
47
Best answers
0
Ratings
32 5
Points
18
#4
Joined
Nov 9, 2013
Messages
63
Best answers
0
Ratings
6 2
Points
8
#5
OnaDavney
Exactly, I changed my IP address and logged into my hosting panel, install firewall software and enabled bot incoming/outcoming ports, back to PuTTY program and I could login to my server. The problem is solved.

Anyway, it was a good experience when changing default ports for SSH :)
 
Older Threads
Replies
1
Views
111
Replies
6
Views
195
Replies
1
Views
97
Replies
2
Views
53
Latest Threads
Replies
9
Views
70
Replies
6
Views
42
fwh
Replies
2
Views
33
Replies
2
Views
34

Latest Hosting OffersNew Reviews

Sponsors

Latest Blog ArticlesMost Viewed Threads

Tag Cloud

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top