403 Forbidden Error On http but not on https

superdev666

Member
Registered
Joined
Mar 15, 2018
Messages
24
Points
3
Hi guys,

When i checked my website using a googlebot test tool from http://www.redirect-checker.org/index.php , i put my site name on it http://domain.net ,
it returned 403 forbidden error , but when i put https://domain.net, it returned with 200 status ok. I am using cpanel. This website is a new website i opened, a wordpress theme, just one post. Also i tried submit sitemap on google webmaster tool console inside, i can't submit on http://domain.net, but able to submit on https://domain.net. it shows 403 error also via google console sitemap submit on http. Other bots like baiduspider, yahoo bot, msn bot, all other bots test showing 200 ok, JUST this googlebot/googlebot mobile.

status check on http :

403 Forbidden Error On http but not on https 1.jpg

status check on https :

403 Forbidden Error On http but not on https 2.jpg

And to into more in-depth of my issue :



i had two old sites that can't submit sitemaps due to 403 error also, both not wordpress sites, but rather a clone over content from main site.

So right now, i have 4 sites :

1) Main site - running on nginx server - Sitemap able to submit / No 403 error / running on http only / https/ssl is not installed /
robot.txt is fine - User-agent: * Disallow: / non wordpress site / using a failover ip

2) New site 1- running on apache server - Sitemap not able to submit on http but able to submit on https / 403 error on google console on http - including status header check / site is with http + https - no redirect to one another, both links can direct access / robot.txt is fine - User-agent: * Disallow: / non wordpress theme / using server ip instead of failover ip - tried using failover ip on it but it doesn't work on the domain, so had to use the server ip instead

3) New site 2- running on apache server - Sitemap not able to submit on http but able to submit on https / 403 error on google console on http - including status header check / site is with http + https - no redirect to one another, both links can direct access / robot.txt is fine - User-agent: * Disallow: / non wordpress theme / using server ip instead of failover ip - tried using failover ip on it but it doesn't work on the domain, so had to use the server ip instead

4) New site 3 - running on apache server - sitemap not able to submit on http but able to submit on https / 403 error on google console on http - including stauts header check / site is with http + https - no redirect to one another, both links can direct access / robot.txt is fine - User-agent: * Disallow: / wordpress theme / using server ip instead of failover ip - tried using failover ip on it but it doesn't work on the domain, so had to use the server ip instead

So new site 3 is a new site i open to test if its the folders issue and also to start a new site again with my old wordpress theme but it turns out the same issue as my other new site 1 / new site 2. Which means, the issue its not the folders inside the root folders of each domain, not permission errors inside either, or the robot texts, not with the firewall either, i have disabled the cpanel firewall, today i called up ovh directly to ask if they have setup firewall on my main server or blocking any googlebots, they said NO, they only provide the machines. So not root folders issue, i have tried set redirect on htaccess inside new site 2 folders -
> https to http on " New site 2 ", but still returned error 403 on googlebot test.

I have even went on freelancer to get help, offering a fee for anyone to can fix this issue, surprisely no one is able to fix it or even found out what is causing the issue, one had over 20 years experience in apache servers, and investigate my apache settings and found no issues with it blocking googlebots. another one with 10 + years experience in cpanel + sitemap also can't find the exact problem, and alot of more developers, programms, system administrators.

Now i am totally helpless with this, my server is also very expensive :

MG-128
Intel 2x Xeon E5-2630v3
16c/32t - 2.4GHz /3.2GHz
128GB DDR4 ECC 1866 MHz
SoftRAID 2x2TB
500 Mbps bandwidth
vRack: not included
€204.99

but showing this error on http (( somehow my main site is able to submit sitemaps on nginx, no error except all the new sites, even for a fresh wordpress website also showing error (( i don't know what happen to my server, or during reboot, cpanel did some nasty updates which blocked all googlebots or something. And now i am doing one last final test to final confirm its something wrong with my server, which is i bought a shared hosting from hostgator and i am going to put this new site 3 again in this new shared hosting and see if there's 403 error, i remember when i first started my first site, it was on http with shared hosting hostgator and it was all smooth, no issues with sitemap at all.

Meanwhile, while i am waitng for hostgator to send me the hosting details, i am welcoming all world's best programmers, developers, 50+ years experience in cpanel ( if any ), or in status code error 403 showing on http but not on https ( in this field ). please do leave a comment with your advice, if you can fix my issue, i am more than willing to pay you a beer !!! ((

This thread is where i found out two new sites having 403 error and started the thread - unfortunately, the help given wasnt able to help me to fix, because now its not the htaccess or robot text issue anymore inside the folders :

http://www.webhostingtalk.com/showthread.php?t=1695988

Additinal information :

1) cpanel auto installed ssl certs on my new sites, main site didn't got renew automatically, since it got moved to nginx.and it seems it only install on apache servers.
2) all bots is allowed access from the websites ( new sites/old sites - i tested all using http://www.redirect-checker.org/index.php), except this googlebot is being rejected from the new sites.

Thank you everyone !!! Please do share this with your friend to help me !!! i really don't want to buy another new server just to bypass this 403 bug ((

**and sorry for my english if its hard to understand, i am from singapore hope someone is able to understand what i am saying lol
 

24x7serverman

Well-known member
Hosting Provider
Registered
Joined
Jul 25, 2017
Messages
651
Points
28
First of all, you will need to fix the DNS issue of your domain name avcollectors.net

Also, I'm not able to ping those nameservers:-

C:\>ping ns1.avcollectors.net
Ping request could not find host ns1.avcollectors.net. Please check the name and try again.

C:\>ping dns1.avcollectors.net
Ping request could not find host dns1.avcollectors.net. Please check the name and try again.

C:\>ping ns2.avcollectors.net
Ping request could not find host ns2.avcollectors.net. Please check the name and try again.

C:\>ping dns4.avcollectors.net
Ping request could not find host dns4.avcollectors.net. Please check the name and try again.
 

superdev666

Member
Registered
Joined
Mar 15, 2018
Messages
24
Points
3
Hi buddy, i am not using those nameservers thats why you unable to ping those, only using 2 nameservers, ns1.shyav.com and ns2.shyav.com. On my domain portal, i have point the dns to this domain also.

First of all, you will need to fix the DNS issue of your domain name avcollectors.net

Also, I'm not able to ping those nameservers:-

C:\>ping ns1.avcollectors.net
Ping request could not find host ns1.avcollectors.net. Please check the name and try again.

C:\>ping dns1.avcollectors.net
Ping request could not find host dns1.avcollectors.net. Please check the name and try again.

C:\>ping ns2.avcollectors.net
Ping request could not find host ns2.avcollectors.net. Please check the name and try again.

C:\>ping dns4.avcollectors.net
Ping request could not find host dns4.avcollectors.net. Please check the name and try again.
 
Latest Threads
Replies
0
Views
30
Replies
0
Views
72
Replies
1
Views
226
Similar Threads

Latest Hosting OffersNew Reviews

Sponsors

Tag Cloud

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top