Are you still using PHP 5.x? Why?

Kaz Wolfe

Well-known member
Joined
Jul 7, 2016
Messages
385
Best answers
0
Ratings
30
Points
28
#1
I am using both PHP 5.6 and PHP 7 because some my scripts require PHP 5.6
What about you? Are you still using PHP 5.x? if yes then why?
 
Joined
Jan 1, 2019
Messages
56
Best answers
0
Ratings
22
Points
8
#2
I am using both PHP 5.6 and PHP 7 because some my scripts require PHP 5.6
What about you? Are you still using PHP 5.x? if yes then why?
Hi Kaz,

I am also using PHP 5.6 as my one of my websites as my web hosting provider is still offering PHP 5.6.
I am not facing any difficulty with the old versions.
 
Joined
Aug 31, 2018
Messages
196
Best answers
1
Ratings
56 3
Points
28
#5
5.6 ended support as of December 31 so if possible i would update your code or find alternatives I would also at advises the earliest version you should run at this point is 7.2
 

WSCallum

New member
Joined
Jul 5, 2018
Messages
12
Best answers
0
Ratings
4
Points
3
#10
Onto latest PHP officially but still offer older versions with CloudLinux - The good thing about CL is that they continue to issue security patches for older versions themselves so whilst it's not recommended to utilise older versions, at least they are still safe for customers to use.
 

Bryan McClure

Well-known member
Joined
Jul 20, 2016
Messages
218
Best answers
0
Ratings
18 1
Points
18
#12
I am using both php 5.6.x and php 7.2.x on different websites and realize that php 7.x for better performance but to get compatible with this version, your website functions need to do carefully.
 
Joined
May 9, 2018
Messages
22
Best answers
1
Ratings
16 6
Points
3
#13
Does CloudLinux also provide injection patching for old Joomla! 1.5 scripts that use these outdated versions of PHP?

Or is CloudLinux just providing these old versions of PHP so you can give your clients a false sense of security that "hey, everything's alright... keep using a decade's old CMS with this secure version of PHP 5."
 
Joined
May 9, 2018
Messages
22
Best answers
1
Ratings
16 6
Points
3
#16
Info?

I think you are misinterpreting my post.

Why do people need to use old and end-of-life versions of PHP? Ask yourself that question.

And the answer will be something along the lines of ... "My *insert script name and version* script doesn't work with PHP 7.1 or later" (In my example, I just happened to use Joomla! 1.5 but you can really insert any script and version that fits the bill here).

So the question then becomes... why are you using that script and that version of the script? Has the script been abandoned by it's developers? Are you refusing to update the script to the latest version?

Using my example of Joomla! 1.5 ... Joomla! has release several versions since 1.5 and 1.5 is now officially dead to Joomla! ... so why are you using and end-of-life and dead version of Joomla!?

Being able to use end-of-life versions of PHP - no matter how much they are propped up with the latest security fixes - isn't going to protect you from exploits in the outdated software you are using with those end-of-life versions of PHP.
 
Latest Threads
Replies
0
Views
2
  • Deleted
  • Deleted by fwh
Replies
0
Views
1
Replies
0
Views
1
Replies
1
Views
21
  • Deleted
  • Deleted by fwh
Replies
0
Views
1

Latest Hosting OffersNew Reviews

Sponsors

Latest Blog ArticlesMost Viewed Threads

Tag Cloud

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top